Free Shipping on most orders over $100!*
Your Shopping CartYour Shopping Cart: 0 Items Your Shopping CartYour Shopping Cart: 0 Items

Your cart is empty.

Call the Mac experts! (888) 769-7629
Sign up for our Max Mail Newsletter!
Meet Max the Sasquatch
Apple Authorized Reseller

Ask Max: Problems with mail

Asked on 10/02/2014:

For over 20 years I have used Microsoft's "Entourage" e-mail program. Well, good old MicroSoft has decided not to support or upgrade it any longer. So, I set up "Mail". After some start-up operator errors, we got along pretty well until about 2 weeks ago.

I began getting messages that my "outgoing" server ID was not correct. I have never touched it and had trouble finding out what they were talking about. The entire "Mail" program has been frozen for over a week. Now, I go directly to Comcast to get my mail.

I spent over an hour with Comcast Support to no avail. The tech heard it might be due to my signature. Really? They said to contact Apple. I'm hoping you can help me before my appointment with them.



It’s possible that Comcast has updated their server configuration which could lead to sending errors.

Go into the account preferences and click the drop down for sending server. In the drop down menu, choose “Edit server list.” Delete the Comcast sending server. Then re-add it based on Comcast’s configuration recommendations. Any existing messages that were created but not sent should be tossed, as they retain the old server information. This has resolved the issue in the past.

Hope this helps!

Check Out with PayPal